Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
arman83
20.01.2023 02:57 •
Информатика
Напишите программу которая определяет является ли заданное натуральное числом квадратом некоторого натурального числа
Ответ:
крыска235
25.08.2020 16:20
Var
n, x: longint;
begin
readln(n);
x := round(sqrt(n));
if x * x = n then
writeln('YES')
else
writeln('NO');
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Jeka990
18.10.2020 08:24
Ребят Напишите наименьшее число x, для которого истинно высказывание: НЕ (x 45) И НЕ ( в числе x нет одинаковых цифр)...
leramoisejenko
17.04.2021 23:26
Перевести из двоичной сс 101101,110 , из восьмеричной 30,1 , из шестнадцатеричной 38,в в десятичную перевести десятичные числа 435 в двоичную, 681 в восьмеричную, 197...
alidniva111
28.01.2020 13:16
Спрограммированиемпочему такой текст? (язык html)...
ilariyao
01.11.2021 05:31
Как формируются векторные кратко надо. много не надо, как вы любите копировать....
tumoannasehko
28.12.2020 15:11
Составьте программу для подсчёта суммы квадратов чисел от 5 до 10 на паскале!...
1830583
18.01.2022 17:35
Составьте программу вывода на экран значений целых чисел от 1 до 7 (в столбик).через паскаль .....
инна103
18.01.2022 17:35
Составьте программу вычисления суммы целых чисел от 1 до k.(через паскаль)...
Найк2006
27.04.2020 06:43
1. для того, чтобы вставить на слайд текстовую надпись, если это не предусмотрено разметкой, нужно: а. сделать двойной щелчок по слайду, затем начать писать с выбранного...
Queen2221
13.10.2020 16:27
Как называется устройство позволяющее объединить компьютеры в сеть wi-fi...
амаеру
28.10.2022 15:07
Как называется ссылка, которая при копировании формулы из одной ячейки в другую не изменяется...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
n, x: longint;
begin
readln(n);
x := round(sqrt(n));
if x * x = n then
writeln('YES')
else
writeln('NO');
end.