В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
юля2738
юля2738
29.09.2020 05:50 •  Информатика

Напишите программу,которая определяет количество отрицательных чисел среди трех введенных.

Ответ:
savoian82ozq31t
savoian82ozq31t
24.09.2020 22:15
//Постарался как можно проще
//Pascal ABC.NET v3.1 сборка 1219

Var
 a,b,c,k:integer;
begin
 read(a,b,c);
 if a<0 then k:=k+1;
 if b<0 then k:=k+1;
 if c<0 then k:=k+1;
 writeln(k);
end.

Пример ввода:
-1
4
-6
Пример вывода:
2
0,0(0 оценок)
Ответ:
Kira1626
Kira1626
24.09.2020 22:15
Var
  i, k, n: integer;

begin
  for i := 1 to 3 do
  begin
    readln(n);
    if n < 0 then k := k + 1;
  end;
 
  writeln(k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?