В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
mashcolor
mashcolor
18.12.2020 00:42 •  Информатика

Написать программу на паскале: даны 3 числа в порядке возрастания-стороны треугольника, вывести сообщение «этот треугольник прямоугольный» решается полугодовая 46

Ответ:
nastya4030
nastya4030
09.10.2020 22:24

var a,b,c: integer;

writeln ('введите стороны прямоугольника')

readln(a,b,c);

if a*a+b*b=c*c than writeln ('этот треугольник прямоугольный') else writeln ('этот треугольник не прямоугольный');

end.

0,0(0 оценок)
Ответ:
kipenkolya
kipenkolya
09.10.2020 22:24

label ra,rb;

var a,b,c: integer;

begin

write('Введите сторону a: ');

readln(a);

ra: write('Введите сторону b: ');

readln(b);

if b>a then

begin

rb: write('Введите сторону c: ');

readln(c);

if c>b then begin

if sqr(c)=sqr(a)+sqr(b) then writeln('Этот треугольник - прямоугольный') else writeln('Этот треугольник - не прямоугольный');

end else begin writeln('Введите число больше, чем ',b); goto rb; end;

end else begin writeln('Введите число больше, чем ',a); goto ra; end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?