В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Anasxon2004
Anasxon2004
18.10.2020 10:01 •  Информатика

Написать программу, которая в качестве результата дает истину, если выполняется заданное условие, или ложь, если условие не выполняется: введенное целое число является квадратом нечетного числа.(mathcad)

Ответ:
kanevskiygabe
kanevskiygabe
09.10.2020 15:49

/


Welcome to GDB Online.

GDB online is an online compiler and debugger tool for C, C++, Python, Java, PHP, Ruby, Perl,

C#, VB, Swift, Pascal, Fortran, Haskell, Objective-C, Assembly, HTML, CSS, JS, SQLite, Prolog.

Code, Compile, Run and Debug online from anywhere in world.


/

#include <stdio.h>

#include <iostream>

#include <math.h>

int main()

{

  int x=0;

 std::cin >> x;

  int tmp = round(sqrt(x));

if (sqrt(x) == tmp && tmp % 2 != 0){

   std::cout << true;

}

else{

   std::cout << false;

}

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?