Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
popovvovapo
25.03.2022 21:20 •
Информатика
Нужна программа на pascal abc, которая будет находить среднее арифметическое n чисел и округлять его до целых. 100 ! !
Ответ:
2710200013
08.10.2020 01:31
Var
i,n,m,s:integer;
begin
Write('n='); Read(n);
s:=0;
for i:=1 to n do begin Read(m); s:=s+m end;
Writeln('Cреднее арифметическое округленно равно ',Round(s/n))
end.
Пример
n=5
3 6 2 4 3
Cреднее арифметическое округленно равно 4
0,0
(0 оценок)
Ответ:
Salazar01
08.10.2020 01:31
Program n1;
var n,i,a,sum: integer;
begin
write('n=');
readln(n);
sum:=0;
writeln('введите ',n,' чисел: ');
for i:=1 to n do
begin
readln(a);
sum:=sum+a;
end;
write('срзнач: ',round(sum/n));
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
ffplfref
27.09.2021 05:52
8. Дан двумерный массив целых чисел. а) Составить программу, определяющую, верно ли, что сумма элементовстроки массива с известным номером оканчивается цифрой 0. МОЖНО ЧЕРЕЗ С++...
Тучка12
12.03.2020 12:12
Построить таблицу истинности CV(A&BVС)...
All2006
13.01.2021 09:02
Как найти сумму элементов в каждой строке двумерного массива pasckal. и если можно произведение элементов в каждом столбце....
Smekalenok
25.05.2021 13:35
Решить : сколько символов содержит текст, записанный в 16-битном коде, объем которого раве 2 кбайта? решить с дано, что найти , и решение...
klimsamgim923dushez
01.12.2022 22:27
Склавиатуры вводится сначала количество чисел, а затем сами числа. найдите сумму всех чётных чисел последовательности....
ДимаМасленников
15.03.2021 23:05
15 возможностей эффектов, которые можно наложить на слайд (например, анимация)...
Demix485
07.03.2022 05:07
Составить программу на языке паскаль, которая запрашивает у пользователя некоторое количество трехзначных чисел и выводит на экран цифру, находящуюся в середине каждого полученного...
антонl
24.01.2020 14:49
На вход два числа – a и b. вывести на экран все числа между ними, которые делятся на 7 или оканчиваются на 3. в паскале...
bhncgfhkjghuiou
30.12.2022 05:11
Исправьте код 20 б program(infinity); begin const pi=3.14; var(i,s,r): real; writeln(bbedi radiys); readln(r); i: =2*pi*r; s: =pi*r*r; writeln(`i=`,i `s=`,s); end ошибка ожидался...
mrscom
21.01.2021 20:22
Считая, что каждый символ кодируется одним байтом, определите чему равен информационный объем сообщения: человек есть то, что он ест . а) 300 байта б) 30 байт с)30 бит ответ...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
i,n,m,s:integer;
begin
Write('n='); Read(n);
s:=0;
for i:=1 to n do begin Read(m); s:=s+m end;
Writeln('Cреднее арифметическое округленно равно ',Round(s/n))
end.
Пример
n=5
3 6 2 4 3
Cреднее арифметическое округленно равно 4
var n,i,a,sum: integer;
begin
write('n=');
readln(n);
sum:=0;
writeln('введите ',n,' чисел: ');
for i:=1 to n do
begin
readln(a);
sum:=sum+a;
end;
write('срзнач: ',round(sum/n));
end.