В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ffplfref
ffplfref
27.09.2021 05:52 •  Информатика

8. Дан двумерный массив целых чисел. а) Составить программу, определяющую, верно ли, что сумма элементов
строки массива с известным номером оканчивается цифрой 0.
МОЖНО ЧЕРЕЗ С++ И ПОЛНОСТЬЮ КОД, ​

Ответ:
kamila0277
kamila0277
01.12.2020 15:18

#include <iostream>

using namespace std;

int main()

{

   int line, column;

   cout << "Введите количество строк и столбцов через пробел: ";

   cin >> line >> column;

   int array[50][50] = {};

   cout << "Введите элементы двумерного массива: \n";

   for (int i = 0; i < line; i++ )

   {

       for (int j = 0; j < column; j++)

       {

           cin >> array[i][j];

       }

   }

   int max = array[0][1];

   int line_number = 1;

   for (int i = 0; i < line; i++)

   {

       int j = 1;

       if (max < array[i][j])

       {

           max = array[i][j];

           line_number = i + 1;

       }

   }

   cout << line_number;

}

Объяснение:

#include <iostream>  // Библиотека ввода - вывода

using namespace std;  // Пространство имен

int main()

{

  int line, column;  // Создание целочисленных переменных, отвечающих за количество строк и столбцов в двумерном массиве

  cout << "Введите количество строк и столбцов через пробел: ";  // Вывод сообщения в консоль

  cin >> line >> column;  // Ввод количества строк и столбцов с клавиатуры

  int array[50][50] = {};  // Создание целочисленного массива размером 50х50

  cout << "Введите элементы двумерного массива: \n";  // Вывод сообщения в консоль

  for (int i = 0; i < line; i++ )  // Цикл для ввода элементов массива

  {

      for (int j = 0; j < column; j++)  // Цикл для ввода элементов массива

      {

          cin >> array[i][j];  // Ввод элементов массива

      }

  }

   int max = array[0][1];  // Присваиваем переменной, хранящей максимум, значение массива в 0 строке и 1 столбце

   int line_number = 1;  // Переменная, хранящая номер строки

   for (int i = 0; i < line; i++)  // Цикл для прогона значений 2-го столбца

   {

       int j = 1;  // // Нужны значения определенного столбца ⇒ значение переменной j будет постоянным

       if (max < array[i][j])  // Если значение переменной max < значения массива i строки и j столбца

       {

           max = array[i][j];  // Значение переменной max = значению массива i строки и j столбца

           line_number = i + 1;  // Номер строки = индекс строки + 1 (т. к. индексация начинается с нуля)

       }

   }

   cout << line_number;  // Вывод ответа

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?