В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Demix485
Demix485
07.03.2022 05:07 •  Информатика

Составить программу на языке паскаль, которая запрашивает у пользователя некоторое количество трехзначных чисел и выводит на экран цифру, находящуюся в середине каждого полученного числа. не в коем случае не используй их: last, const, count. делай обыкновенным

Ответ:
марго170
марго170
16.08.2020 21:00
Var i, x, y: integer;

a: array [1..255] of integer;
function sr(i: integer):string;

begin

sr:=inttostr(i)[2];

end;
begin

writeln('Vvedite kol-vo chisel');

read(x);

for i:=1 to x do read(a[i]);

writeln();

for i:=1 to x do writeln(sr(a[i]));

end.
0,0(0 оценок)
Ответ:
lenaivashenko16
lenaivashenko16
16.08.2020 21:00
Program n_5;
var
   a, b, c: real;
procedure n_1;
begin
 if ((a<b) and (a>c)) or ((a<c) and (a>b)) then
  write (a)
 else
  if ((b<a) and (b>c)) or ((b<c) and (b>a)) then
   write (b)
  else
   if ((c<a) and (c<b)) or ((c<b) and (c>a)) then
    write (c);
end;
begin
 writeln ('Введите три трёхзначных числа');
 readln (a);
 readln (b);
 readln (c);
 if ((a >= 100) and (a <= 999) and (a <> b) and (a <> c)) and ((b >= 100) and (b <= 999) and (b <> a) and (b <> c)) and ((c >= 100) and (c <= 999) and (c <> a) and (c <> b)) then n_1
 else
  write ('ERROR');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?