В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
dimabolnygin
dimabolnygin
16.02.2022 11:08 •  Информатика

38 напишите программу на языке паскаль которая находит сумму первых 50 членов прогрессии и выводит их в строку

Ответ:
NoName353647
NoName353647
07.10.2020 23:29
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (b1,q):=ReadReal2
      ('Введите значение первого члена и знаменателя прогрессии:');
  Writeln('Сумма первых 50 членов прогрессии равна ',
      b1*(1-q**50)/(1-q));
  Write('Члены прогрессии: '); SeqGen(50,i->b1*q**i).Println;
end.

Пример
Введите значение первого члена и знаменателя прогрессии: 1.2 2.3
Сумма первых 50 членов прогрессии равна 1.12623675002648E+18
Члены прогрессии: 1.2 2.76 6.348 14.6004 33.58092 77.236116 177.6430668 408.57905364 939.731823371999 2161.3831937556 4971.18134563788 11433.7170949671 26297.5493184244 60484.363432376 139114.035894465 319962.282557269 735913.249881719 1692600.47472795 3892981.09187429 8953856.51131087 20593869.976015 47365900.9448345 108941572.173119 250565615.998174 576300916.795801 1325492108.63034 3048631849.84979 7011853254.65451 16127262485.7054 37092703717.1224 85313218549.3814 196220402663.577 451306926126.227 1038005930090.32 2387413639207.74 5491051370177.81 12629418151409 29047661748240.6 66809622020953.4 153662130648193 353422900490843 812872671128940 1.86960714359656E+15 4.30009643027209E+15 9.8902217896258E+15 2.27475101161393E+16 5.23192732671205E+16 1.20334328514377E+17 2.76768955583067E+17 6.36568597841055E+17
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?