В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Написать программу, на языке си, выводящую все чётные числа на отрезке от a до b. в этой нельзя использовать инструкцию if.

Ответ:
Oхxxymiron
Oхxxymiron
09.09.2020 15:27
#include <stdio.h>
#include <conio.h>
int main (int argc, char *argv[])
{
    int A, B;
    printf("A = ");scanf("%d", &A);
    printf("B = ");scanf("%d", &B);
    A = A + A % 2;
    B = B - B % 2;
    for (A = A; A<=B; A = A+2)
        printf("%d ", A);
    getch();
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?