В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
annapar2017p00w0y
annapar2017p00w0y
26.01.2021 05:25 •  Информатика

Составьте программу возведения в квадрат всех целых чисел от 0 до 50. 1 )использовать цикл с предусловием. 2 )использовать цикл с постусловием. 3 )использовать цикл с параметром.

Ответ:
просвятленный
просвятленный
26.08.2020 20:06
Program sqr;
Var i:integer;
begin
  while i <= 50 do //1)
    begin
      write(i*i, ' ');
      Inc(i);
    end;
  i:=0;
  writeln;
  repeat         //2)
    write(i*i, ' ');
    Inc(i);
  until i > 50;
  writeln;
  for i:=1 to 50 do write(i*i, ' '); //3)
end.
0,0(0 оценок)
Ответ:
maker1287
maker1287
26.08.2020 20:06
2)#include<iostream>#include <stdlib.h>#include<math.h>using namespace std;int main(){int c=0, b;do{

    b = pow( c, 2);    c++;    cout << b << " ";}    while(c<51);    system("pause");
}

1)#include<iostream>#include <stdlib.h>#include<math.h>using namespace std;int main(){int c=0, b;
    while(c<51){

    b = pow( c, 2);    c++;    cout << b << " ";}    system("pause");
}
3)#include<iostream>#include <stdlib.h>#include<math.h>using namespace std;int main(){int c=0, b;
    for(c; c<51; c++){

    b = pow( c, 2);    cout << b << " ";}    system("pause");
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?