В
Все
Г
Геометрия
Д
Другие предметы
У
Українська література
Э
Экономика
Г
География
О
ОБЖ
М
Математика
Л
Литература
Х
Химия
Қ
Қазақ тiлi
М
МХК
О
Обществознание
У
Українська мова
А
Алгебра
А
Английский язык
Ф
Физика
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
Р
Русский язык
О
Окружающий мир

Найдите наибольший по модулю элемент заданного массива из 9 действительных чисел (программка)

Ответ:
daniil10457899Yb
daniil10457899Yb
07.08.2020 08:50
// PascalABC.NET 3.0, сборка 1160 от 05.02.2016
begin
  var a:=ReadArrReal('Введите 9 чисел:',9);
  var imax:=0;
  for var i:=1 to 8 do
    if abs(a[i])>abs(a[imax]) then imax:=i;
  Writeln('Наибольшее по модулю: ',a[imax])
end.

Тестовое решение:
Введите 9 чисел: 7 13 0 -4 8 13 -7 -14 2
Наибольшее по модулю: -14
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?