Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
AlsiMaksimowa
08.12.2022 08:01 •
Информатика
Напишите программу(pascal) найдите сумму всех вводимых с клавиатуры чисел, кратных заданному числу а.
Ответ:
darth0
20.08.2020 14:12
Program n1;
var sum,a,c: integer;
begin
readln(a);
sum:=0;
while true do
begin
readln(c);
if c=0 then break;
if c mod a=0 then sum:=sum+c;
end;
writeln(sum);
end.
0,0
(0 оценок)
Ответ:
Anonim2118
20.08.2020 14:12
Предполагается, что ввод завершает число 0
// PascalABC.NET 3.2, сборка 1385 от 14.02.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadInteger('a=');
Writeln(ReadSeqIntegerWhile(x->x<>0).Where(x->x mod a=0).Sum)
end.
Пример
a= 2
5 7 12 8 -4 3 11 0
16
0,0
(0 оценок)
Популярные вопросы: Информатика
ydaschamp
07.05.2020 20:09
Is Great Britain a monarchy...
тупикл12
03.02.2023 07:36
Вообщем, на ноутбуках есть кнопка fn и кнопки f1, f2, f3 и так далее до f12. На ноутбуках надо было зажать кнопку fn, чтобы клавиши f1, f2... были активными. Я что-то сделал...
Арти1234567890
15.10.2022 06:28
Не открывается игра геншин. Захожу,и вылезает текст о последствиях от игры и игра просто вылетает. Перезагрузила компьютер и ничего не изменилось...
alicegluskin
18.09.2022 12:17
рассчитать суммарный подоходный налог рабочих, имеющих налоговые вычеты( функция СУММЕСЛИ()). Не понимаю где диапазон, критерий, диапазон_суммирования...
Kaishuudee
06.12.2021 21:53
пайтон программа Напишите программу, которая посчитает сумму первых десяти натуральных чисел. Sample Input: Sample Output: 55...
анель1011
17.01.2023 03:07
Составить программу, подсчитывающую количество отрицательных элементов массива....
olyabat
29.11.2022 00:30
Сложное высказывание А& В истинно только в том случае, когда истинны оба входящих в него высказывания. Истинность такого высказывания задается следующей таблицей: Выберите...
Sanchos106
22.09.2022 00:50
Выберите несколько вариантов ответа Выберите из списка все файлы, подходящие под маску ?a*.d* plan.doc mama.docx palma.txt lampa.ddt astra.dd ra.doc...
аааааааааппппппааааа
14.05.2023 01:41
Среди предложенных множеств укажите пустые множества. Множество листьев на сосне Множество двузначных положительных чисел, меньших 9 Множество животных на Марсе Множество...
ArtyomKashin
26.01.2023 09:54
1. В чем суть системного подхода? 2. В чем суть системного эффекта? 3. Привидите примеры материальных, нематериальных, смешанных систем?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var sum,a,c: integer;
begin
readln(a);
sum:=0;
while true do
begin
readln(c);
if c=0 then break;
if c mod a=0 then sum:=sum+c;
end;
writeln(sum);
end.
// PascalABC.NET 3.2, сборка 1385 от 14.02.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadInteger('a=');
Writeln(ReadSeqIntegerWhile(x->x<>0).Where(x->x mod a=0).Sum)
end.
Пример
a= 2
5 7 12 8 -4 3 11 0
16