В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Svetlanaaaa16
Svetlanaaaa16
19.09.2022 06:32 •  Информатика

Надо, . 1. составьте программу вычисления суммы чисел в диапазоне от 13 до 113. 13+14+15+ +113 2. составьте программу вычисления суммы чисел кратных 5 в диапазоне от 5 до 105. 3. составьте программу, которая выводит на экран числа кратные 2 и 7 в диапазоне от 2 до 120.

Ответ:
samuskevich
samuskevich
07.08.2020 09:42
Var 
b,i:integer;
Begin  for i:= 13 to 113 do   
b:=b+i; 
Writeln('Сумма чисел в диапазоне от 13 до 113 = ',b); 
b:=0; 
for i:= 5 to 105 do   
if (i mod 5) = 0 then      b:=b+i; 
Writeln('Сумма чисел кратных 5 в диапазоне от 5 до 105 = ',b);   
b:=0; 
Writeln('Числа кратные и 2 и 7 в диапазоне от 2 до 120 );   
for i:= 2 to 120 do   
if ((i mod  2) = 0) and ((i mod 7) = 0) then write(i,' '); 
end.  

Всё просто. Если разделять на программы, то каждый новый цикл это другая программа.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?