В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
anyadorr
anyadorr
18.12.2022 09:12 •  Информатика

Требовалось написать программу, которая определяет, можно ли построить треугольник из отрезков с длинами х, у, z. программа должна выводить соответствующее текстовое сообщение. программист сделал в программе ошибки. var х, у, z: real; begin readln (x, у, z); if (x + y > z) then begin if (x + z > y) then if (y + z > x) then writeln('треугольник построить можно'); end else writeln('треугольник построить нельзя'); end последовательно выполните : 1. пример таких чисел х, у, z, при которых программа неверно решает поставленную . 2. укажите, как нужно доработать программу, чтобы не было случаев ее неправильной работы (можно указать один из доработки исходной программы). 3. укажите, как можно доработать программу, чтобы она вместо вложенных операторов if содержала логическую операцию and. нужен подробный ответ.

Ответ:
rsavka59
rsavka59
16.07.2020 19:25
Если ввести X или Y значительно больше чем Z то программа на втором или тертьем условии выдаст false и закончит свою работу ничего не написав. Например: если указать X = 10 , Y = 2, Z = 3; то на первом условии будет true, потому что 10 +2 > 3 , но на третьем условии выдаст false потому что 2+3 < 10 но так как ничего не прописано на этот случай программа просто закончит свою работу.
Что бы исправить этот баг необходимо все условия свести в одно: 
if ((x + y > z)and (x + z > y) and (y + z > x) ) then 
   writeln('треугольник построить можно')
else  
 writeln('треугольник построить нельзя');
end.

Это решение так же является ответом на 3-й вопрос.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?