В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Elenka9272
Elenka9272
15.02.2023 12:43 •  Информатика

Написать программу в паскале.заполнить массив случайными величинами от -100 до 100.найти сумму элементоав массива.

Ответ:
SASHEKA
SASHEKA
07.10.2020 09:55
Const n=10;
var a:array[1..n] of integer;
i,s:integer; 
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
 begin
 a[i]:=random(201)-100;
 write(a[i]:4);
 end;
writeln;
s:=0;
for i:=1 to n do s:=s+a[i];
writeln('s = ',s);
end.

Пример:
Массив A:
71 -39 57 33 52 -96 77 -79 -71 -79
s = -74
0,0(0 оценок)
Ответ:
bililife
bililife
07.10.2020 09:55
//PascalABC.NET
//Версия 3.3. сборка 1583 (25.11.2017)

begin
 var a:array[1..100] of integer;
 var n,s:integer;
  write('Введите размер массива: ');readln(n);
  for var i:=1 to n do 
  begin
   a[i]:=random(-100,100);
   write(a[i],' ');
   s:=s+a[i];
  end;
  writeln;
  writeln('Сумма: ',s);
 readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?