В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
kategarkysha
kategarkysha
22.06.2021 06:17 •  Информатика

Составить программу, устанавливающую одного ли знака два числа, вводимые клавиатуры

Ответ:
nikitatutaev03
nikitatutaev03
01.10.2020 23:01
var
  a, b: integer;
begin
  readln(a, b);
  writeln(System.Math.Sign(a) = System.Math.Sign(b) ? 'Да' : 'Нет');
end.

Или  ̶п̶р̶и̶м̶и̶т̶и̶в̶н̶е̶е̶  проще:
var
  a, b: integer;
begin
  readln(a, b);
  if (a > 0) then a := 1;
  if (a = 0) then a := 0;
  if (a < 0) then a := -1;
  if (b > 0) then b := 1;
  if (b = 0) then b := 0;
  if (b < 0) then b := -1;
  if (a = b) then
    writeln('Yes')
  else
    writeln('No');
end.

Немного  ̶у̶п̶р̶о̶̶щ̶̶ё̶н̶н̶ы̶й̶  оптимизированный вариант:
var
  a, b: integer;
begin
  readln(a, b);
  if (a > 0) then 
    a := 1
  else
    if (a = 0) then
      a := 0
    else
      a := -1;
  if (b > 0) then 
    b := 1
  else
     if (b = 0) then 
       b := 0
     else
       b := -1;
  if (a = b) then
    writeln('Yes')
  else
    writeln('No');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?