В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
pnzarKarina
pnzarKarina
07.04.2020 05:14 •  Информатика

Составить программу вычисления функции на языке PASCAL(номер 1 и 3)


Составить программу вычисления функции на языке PASCAL(номер 1 и 3)

Ответ:
kino2011
kino2011
23.06.2020 00:47

1.

program prog;  

var  

  x,y:real;  

begin  

 writeln('x=?');  

 readln(x);  

 if x<=-4 then  

   y:=x*x*x-2;  

 if 6<=x then  

   y:=40-x;  

 if (-4<x) and (x<6) then  

   y:=x*x;  

 writeln('y ',y:1:3)  

end.

3.

program prog;  

var  

  x,y:real;  

begin  

 writeln('x=?');  

 readln(x);  

 if x<1 then  

   y:=2*x-17;  

 if (1<=x) and (x<=5) then  

   y:=exp(ln(x)*7);  

 if 5<x then  

   y:=x*ln(x);  

 writeln('y ',y:1:3)  

end.

exp(ln(x)*n)

,где n - степень , x - выражение.

(используется во втором упражнение которое я решил, согласитесь лучше будет выглядеть чём х*х*х*х*х*х*х)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?