В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
dudich97
dudich97
06.10.2021 12:10 •  Информатика

написать программу на C#
В данной действительной квадратной матрице порядка n найти сумму элементов строки, в которой расположен элемент с наименьшим значением. Предполагается, что такой элемент единствен.

Ответ:
Meri1314
Meri1314
13.10.2020 22:03

using System;

namespace ConsoleApp1

{

   class Program

   {

       static void Main(string[] args)

       {

           int n,i,j, imin = 0;

           double sum = 0;

           Console.Write("Введите n: ");

           n = Convert.ToInt32(Console.ReadLine());

           double[,] A = new double[n, n];

           Random r = new Random();

           for (i = 0; i < n; i++)

           {

               for (j = 0; j < n; j++)

               {

                   A[i, j] = r.NextDouble()*100 - 50;

                   Console.Write("{0,10:0.0}", A[i, j]);

                   if (A[i, j] < A[imin / 10, imin % 10]) imin = i * 10 + j;

               }

               Console.WriteLine();

           }

           i = imin / 10;

           for (j = 0; j < n; j++) sum += A[i, j];

           Console.WriteLine("Сумма элементов строки с наименьшим значением: {0,10:0.0}", sum);

       }

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?