В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
neush
neush
25.02.2023 10:24 •  Информатика

Составить программу в Паскале для обработки одномерного массива из 15 чисел. Значения элементов массива задать с клавиатуры самостоятельно. Найти наименьший элемент массива и его номер. В отчет включить программный код и результат работы программы в виде скриншота. Программная реализация обязательна.

Задание 2

Составить программу в Паскале для обработки одномерного массива из 10 чисел Х=(-17,3; 13,2; -7; -2,36; 123,4;-0,3; 12,356; 142;0; -1). Вычислить количество элементов массива с нечетными номерами на отрезке [5,1..32,4]. В отчет включить программный код и результат работы программы в виде скриншота. Программная реализация обязательна.

Ответ:
kseniya20072
kseniya20072
20.05.2020 12:43

1. program mas_min_el_i_no;

const n=15;

var

a:array[1..n]of integer;

i,m,k:integer;

begin

for i:=1 to n do

begin

write(i,'》');

read(a[i]);

end;

m:=a[1];

k:=1;

for i:=1 to n do

if a[i]<m then

begin

m:=a[i];

k:=i;

end;

writeln;

write(m,' ',k)

end.

2. program mas_kolel_v_otr_s_nech_ind;

const

x:array[1..10]of real=(-17.3, 13.2, -7, -2.36, 123.4,-0.3, 12.356, 142,0, -1);

var

i,k:byte;

begin

k:=0;

for i:=1 to 10 do

if (x[i]>=5.1)and(x[i]<=32.4)and(i mod 2<>0) then

inc(k);

write(k)

end

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?