В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
umnik84530
umnik84530
20.06.2020 13:44 •  Информатика

«A»: Напишите программу, которая находит количество четырёхзначных чисел, которые делятся на 7. «B»: Ипполит задумал трёхзначное число, которое при делении на 15 даёт в остатке 11, а при делении на 11 даёт в остатке 9. Напишите программу, которая находит все такие числа.
«C»: С клавиатуры вводится натуральное число N. Программа должна найти факториал этого числа (обозначается как N!) – произведение всех натуральных чисел от 1 до N. Например,
5! = 1 • 2 • 3 • 4 • 5 = 120.
«D»: Натуральное число называется числом Армстронга, если сумма цифр числа, возведенных в N-ную степень (где N – количество цифр в числе) равна самому числу. Например, 153 = 13 + 53 + 33. Найдите все трёхзначные Армстронга.

Ответ:
dashadod
dashadod
13.01.2022 03:27

Python:

# A

print(len([i for i in range(1000, 10000) if i % 7 == 0]))

# B

for i in range(100, 1000):

   if all([i % 15 == 11, i % 11 == 9]):

       print(i)

# C(1)

N = int(input())

numbers = [i for i in range(1, N+1)]

result = numbers[0]

for i in numbers[1:]:

   result *= i

print(result)

# C(2)

import math

print(math.factorial(int(input(

# D

for i in range(100, 1000):

   digits = [int(n) for n in str(i)]

   with_a_degree = [n ** len(str(i)) for n in digits]

   if sum(with_a_degree) == i:

       print(i)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?