В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Капач
Капач
05.10.2020 16:41 •  Информатика

Написать программу на паскале: даны 3 числа, если это куб-найти объём, если это параллелепипед-найти площадь поверхности

Ответ:
kthjxrfqqq
kthjxrfqqq
09.10.2020 22:32

var a,b,c,k: real;

begin

write('Введите 1 число: ');

readln(a);

write('Введите 2 число: ');

readln(b);

write('Введите 3 число: ');

readln(c);

if (a=b) and (b=c) and (a=c) then

begin

k:=a*b*c;

writeln('Объем куба равен ',k);

end else

begin

k:=2*(a*b+b*c+a*c);

writeln('Площадь поверхности параллелипипеда равна ',k);

end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?