В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
aspier2016
aspier2016
24.08.2020 15:15 •  Информатика

Нужно составить программу на языке паскаль сортировка от максимального к минимальному элементу чисел одновременного массива стандартного числа от -100 до 100

Ответ:
pron1983
pron1983
23.07.2020 09:17
Var
n,i,j,c:integer;
a:array[1..201] of integer;
begin
 writeln('введите колөво элементов массива');
 readln(n);
 for i:=1 to n do a[i]:=-100+random(201);
 writeln('Исходный массив');
 for i:=1 to n do write(a[i]:5);
 writeln;

 for i:=1 to n-1 do
 for j:=i+1 to n do
 if a[i]<a[j] then
 begin
    c:=a[j];
    a[j]:=a[i];
    a[i]:=c;
 end;

 writeln('Отсортированный массив');
 for i:=1 to n do
 write(a[i]:5);
 writeln;

 end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?