В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Maga052005
Maga052005
04.05.2021 21:28 •  Информатика

Дано натуральное 4-х значное число. напишите программу, которая считает и выводит ответ на вопрос получает новое число, содержащие цифры первоначального числа, записанные в обратном порядке и вывести это число на экран и сумму изначально заданного числа и и полученного числа.

Ответ:
Тупик101
Тупик101
21.08.2020 21:18

program t;

var n, n2, s: integer;

begin

readln(n);

n2:=(n mod 10)*1000+(n div 10 mod 10)*100+(n div 100 mod 10)*10+(n div 1000);

s:=n+n2;

writeln(n2);

writeln(s)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?