В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
svetbuxzp51
svetbuxzp51
18.10.2021 10:59 •  Информатика

Решение нужно в паскале. составьте программу вычисления суммы элементов двумерного массива a(n,n), расположенных под побочной диагональю

Ответ:
arinakurbatovu
arinakurbatovu
24.07.2020 15:00
            Const n=4;
Var x:array [1..n,1..n] of integer;
s,i,j:integer;
begin   
randomize;
    for i:=1 to n do begin   
     for j:=1 to n do begin 
           x[i,j] := random(100);   
        write(x[i,j]:6);     
   end;   
     writeln; 
   end; 
   s:=0; 
 for i:=1 to n do 
for j:= 1 to n do 
if i + j < n + 1
then
s := s + x[i, j]; 
writeln('s=',s); 
readln;
 end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?