В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
leo310106
leo310106
23.03.2020 01:22 •  Информатика

Необходимо решить следующую предметную и написать программу на языке паскаль. для любого целого k обозначим количество цифр в его десятичной записи ц(k). например: ц(1)=1, ц(9)=1, ц(10)=2. дано натуральное число n. вычислить: ( ц(1)/1 ) + ( ц(2)/2^2 ) + +( ц(n)/n^2 )

Ответ:
leraklybnika
leraklybnika
09.10.2020 13:21

program crash;

 

var n, k: integer;

   r: real;

 

begin

 write('n = ');

 readln(n);

 k := 0;

 r := 0;

 while n > 0 do

   begin

     k := k + 1;

     r := r + (n mod 10) / (k * k);

     n := n div 10

   end;

 writeln('r = ', r:0:14);

 readln

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?