В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
mixailoborin0
mixailoborin0
26.02.2021 11:38 •  Информатика

Дано натуральное двузначное число. составить программу определения, является ли сумма его цифр двузначным числом. если нет, то через сколько чисел встретиться первое двузначное число, удовлетворяющее этому условию.на паскале

Ответ:
alobatsevi4
alobatsevi4
09.10.2020 11:48

var

x,x1:integer;

begin

readln(x);

if (x div 10 + x mod 10 >= 10) then writeln ('Является')

else begin  x1:=x; while (x1 div 10 + x1 mod 10 < 10) do x1:=x1+1; end;a

if (x div 10 + x mod 10 < 10) then writeln('Нужно увеличить на ',x1-x);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?