В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
kitty67
kitty67
26.07.2020 18:27 •  Информатика

10 класс составьте программу, позволяющую ввести фамилию, имя и отчество учащегося, разделенные пробелом, и вывести фамилию и инициалы. пример ввода: иванов сергей михайлович { строка s } пример вывода: иванов с. м. паскаль

Ответ:
kmarkechko
kmarkechko
04.08.2020 20:33

var

str: string;

i,k: integer;

begin

write('Введите фамилию, имя и отчество: ');

readln(str);

for i:=1 to length(str) do

begin

if (str[i]<>' ')and(k=0) then

write(str[i]) else

if str[i]=' ' then

begin

inc(k);

write(' ',str[i+1],'.');

end;

end;

readln;

end.


попробуй эту программу.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?