В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
avaitekhovich
avaitekhovich
04.03.2022 02:07 •  Информатика

Составьте программу подсчета общего количества слогов "не", "не" во введенной с клавиатуры строке s. пример ввода: не стыдно не знать - стыдно не учиться.

Ответ:
Germionochka
Germionochka
09.10.2020 05:34
PascalABC.NET 3.4.2, сборка 1837 от 11.10.2018Внимание! Если программа не работает, обновите версию!

begin

 ReadlnString.MatchValues('[Нн]е').Count.Println

end.

0,0(0 оценок)
Ответ:
tomahvisucik16
tomahvisucik16
09.10.2020 05:34

var s:string;

i,k:integer;

begin

write ('Введите строку: ');

readln (s);

for i:=1 to length(s)-1 do

if ((s[i]='н') or (s[i] = 'Н')) and ((s[i+1] = 'е') or (s[i+1] = 'Е')) then k:=k+1;

write ('Количество слогов не равно: ',k)

end.


Составьте программу подсчета общего количества слогов не, не во введенной с клавиатуры строке s.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?