В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Kanmoen014
Kanmoen014
15.06.2022 11:24 •  Информатика

Нужно написать программу на pascal. программа должна выводить 20 случайных чисел от 1 до 26 и чтобы они не повторялись. числа должны сохранятся в массиве. заранее !

Ответ:
needhomework19
needhomework19
08.10.2020 22:03
Var a:array[1..20] of integer;
c,b,i,d: integer;
begin
c:=0;
b:=0;
for i:= 1 to 20 do
begin
a[i]:=random (1,26);
while (b <> 1) do
begin
for d:= 1 to i-1 do
if (a[i] = a[d]) then c:=1;
if (c = 1) then a[i]:=random (1,26) else b:=1;
c:=0;
end;
end;
for i:= 1 to 20 do
writeln(a[i]);
end.

P.S. Не уверен что правильно,т.к. не могу проверить программу в паскале
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?