В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Бантюсик
Бантюсик
19.12.2022 00:51 •  Информатика

Написать программу вычисления суммы целых чисел от 1 до n, запрашиваемого с клавиатуры. pascal abc

Ответ:
arsen992015
arsen992015
21.08.2020 16:25
Var
  i, n: integer;
  sum: longint;
begin
write('n = ');
readln(n);
for i := 1 to n do sum := sum + i;
writeln('Сумма чисел от 1 до ', n , ' = ', sum);
end.
0,0(0 оценок)
Ответ:
10count
10count
21.08.2020 16:25
Var
  s,n:integer;
begin
  Write('Введите n:');
  Readln(n);
  s:=n+(n*(n-1)) div 2; { сумма арифметической прогрессии }
  Writeln('Сумма чисел от 1 до ',n,' равна ',s)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?