В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
89280704228
89280704228
11.12.2020 05:33 •  Информатика

Написать программу, вводящую с клавиатуры целые числа и вычисляющую их сумму до тех пор, пока эта сумма не станет больше 1000. В этом случае программа должна напечатать вычисленную сумму и завершиться. (С программы Java)

Ответ:
jrihdevhdve
jrihdevhdve
29.11.2020 12:02

import java.util.Scanner;

public class Main{

   public static void main(String[] args) {

       Scanner sc = new Scanner(System.in);

       int sum = 0, x;

       while(sum <= 1000){

           x = sc.nextInt();

           sum = sum + x;

       }

       System.out.println(sum);

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?