В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Julia28122002
Julia28122002
14.08.2022 20:59 •  Информатика

Написать программу на языке c++, которая создает и выводит 2x2 квадратную матрицу на экран. после того как матрица появилась на экране, программа должна посчитать её определитель.

Ответ:
тогжан22
тогжан22
08.10.2020 21:05
#include <iostream>
#include <time.h>
using namespace std;
int main() {
 setlocale(0, "RUS");
 srand(time(NULL));
 int matr[2][2];
 cout << "Сгенерированная матрица:" << endl;
 for (int i = 0; i < 2; i++) {
  for (int j = 0; j < 2; j++) {
   matr[i][j] = rand() % 10;
   cout << matr[i][j] << " ";
  }
  cout << endl;
 }
cout << "Определитель матрицы: " << matr[0][0] * matr[1][1] - matr[0][1] * matr[1][0] << endl;
system("pause");
}
0,0(0 оценок)
Ответ:
lolshik009
lolshik009
08.10.2020 21:05
#include <iostream>
#include <vector>
int main()
{
    std::vector<std::vector<size_t>> v2d = { { 5, 4 }, { 3, 5 } };
    for (const auto& i : v2d)
        for (const auto& j : i)
            std::cout << j;
    std::cout << v2d.at(0).at(0) * v2d.at(1).at(1) - v2d.at(0).at(1) *
v2d.at(1).at(0);
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?