В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
elenareznik201
elenareznik201
22.02.2023 04:07 •  Информатика

Нужно написать программу на с++, которая будет решать введенные в нее производные, например 2x^5 = 10x^4, cosx = - sinx, вычислять ответ производной не нужно.

Ответ:
Нинакристярита
Нинакристярита
21.08.2020 16:18
//Microsoft (R) C/C++ Optimizing Compiler Version 19.00.23506 for x64

#include <iostream>
#include <string>
#include <vector>
#include <utility>

int main()
{
    std::vector<std::pair<std::string, std::string>> deriv_sheet = {
        std::make_pair("2x^5", "10x^4"),
        std::make_pair("cosx", "-sinx")
    };
    std::string user_fx;
    std::cin >> user_fx;
    for (const auto& i : deriv_sheet )
        if (i.first.compare(user_fx) == 0)
            std::cout << i.second;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?