В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
rdta
rdta
14.10.2020 15:38 •  Информатика

Напишите программу на с# или на алгоритмическом языке, которая бы определяла количество пар чисел, подряд идущих элементов массива, в сумме не превышающих 217. массив должен содержать 50 неотрицательных чисел, не превышающих 1000. (нужно ).

Ответ:
maksimmolotov2
maksimmolotov2
08.10.2020 20:14
Using System;
namespace ConsoleApp1
{
    class Program
    {
        static void Main(string[] args)
        {
            Random r = new Random();
            int[] a = new int[50];
            int k = 0;
            for(int i = 0;i<50;i++)
            {
                a[i] = r.Next(1001);
                Console.WriteLine("a[" + i + "] =" + a[i]);
            }
            for (int i = 0; i < 49; i++)
            {
                if (a[i]+a[i+1] <= 217)
                {
                    k++;
                }
            }
                Console.WriteLine("Кол-во пар :" + k);
                Console.ReadKey();
        }
    }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?