В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
06062007ивант
06062007ивант
10.12.2020 22:22 •  Информатика

Паскаль написать программу которая по введенному четырехзначному числу выводит сумму его цифр.

Ответ:
kseniahas7
kseniahas7
06.10.2020 07:08
// PascalABC.NET 3.2, сборка 1437 от 03.05.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var t:=Abs(ReadInteger('n='));
  var s:=0;
  while t>0 do begin
    s:=s+t mod 10;
    t:=t div 10
    end;
  Writeln('Сумма цифр равна ',s)
end.

Пример
n= 3048
Сумма цифр равна 15

Замечание: число не обязательно должно быть четырехзначным и не обязательно положительным.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?