В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
katrina7
katrina7
21.10.2020 11:00 •  Информатика

Составить программу в паскале.расчет значения функции x-2/sqrt(x*x-2*x) при х из отрезка (-10; 10) изменяющимся с шагом 1.должен быть цикл for.заранее

Ответ:
Мила5411
Мила5411
21.08.2020 15:19
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  for var x:=-10 to 10 do
    Writeln(x:3,x-2/Sqrt(x*x-2*x):15:10)
end.

Как видно из представленных во вложении результатов, современный Паскаль легко справляется и с отрицательным значением подкоренного выражения (NaN - Not a Number - не число) и с делением на ноль (-infinity - минус бесконечность).

Составить программу в паскале.расчет значения функции x-2/sqrt(x*x-2*x) при х из отрезка (-10; 10) и
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?