В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Bigrash
Bigrash
15.06.2022 04:42 •  Информатика

Написать программу вычисления стоимости покупки. нужно указать вид товара, его цену и количество. вид экрана во время работы программы: вычисление стоимости покупки. введите исходные данные: какой товар вы покупаете? -> тетрадь по какой цене? -> 1.50 сколько штук? -> 5 ваш товар - тетрадь. стоимость покупки: 7.50 сколько денег даете? -> 10 ваша сдача: 2.5

Ответ:
какасика
какасика
20.07.2020 16:17
Var money, cost,summa : real;
count : integer;
 tovar: string;
begin writeln('Введите исходные данные: ');
  writeln('Какой товар вы покупаете? ');
 readln(tovar);
  writeln('По какой цене? ');
 readln(cost);
  writeln('Сколько штук? ');
 readln(count);
  summa := cost*count; writeln('Ваш товар - ', tovar, '. Стоимость покупки: ',summa:0:2);  writeln('Сколько денег даете? ');
 readln(money);
  if money=summa then writeln('свободен, под расчёт') else if money > summa then writeln('Ваша сдача: ', money-summa) else writeln('Нужно добавить: ', summa-money,. ');
 end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?