В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
1000Умник
1000Умник
30.11.2020 09:34 •  Информатика

Снаписанием программы в pascal. напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 5. программа получает на вход количество чисел в последовательности, а затем сами числа. в последовательности всегда имеется число, кратное 5. количество чисел не превышает 100. введённые числа не превышают 300. программа должна вывести одно число – сумму чисел, кратных 5.

Ответ:
Настюша1118
Настюша1118
08.10.2020 16:51
Var
  n, sum, i, a: integer;
begin
  read(n);
  sum = 0;
  for i := 1 to n do
  begin
    read(a);
    if (a mod 5 = 0) then
      sum := sum + a;
  end;
  write(sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?