В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Lena5737488
Lena5737488
24.05.2022 07:32 •  Информатика

1.написать программу, которая определяет наибольшее отрицательное целое число в массиве из 10 элементов. значения элементов массива вводятся пользователем. 2.написать программу, которая определяет наибольшее по модулю число в массиве из 10 введенных пользователем чисел.

Ответ:
elmariya
elmariya
08.10.2020 15:05
1.
var
mas: array[0..10] of Integer ;
i,min,j: Integer;

begin
min:=0;
writeln('Введите числа:');
for i := 1 to 10 do begin

ReadLn(mas[i]);
if (mas[i] <0)
then j:=mas[i];
if j then min:=j;
end;
WriteLn('Минимальное отрицательное число:',min);

end.

2.
var
mas: array [0..10] of Integer;
i, max, j: Integer;

begin
writeln('Введите числа:');
for i := 1 to 10 do
begin
ReadLn(mas[i]);
if abs(mas[i - 1]) < abs(mas[i]) then
max := mas[i] ;
end;
WriteLn('Наибольшее по модулю число:', max);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?