Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
andriyzhovniryk
15.09.2022 18:42 •
Информатика
Решить по программированию, используя, а) оператор ветвления б) оператор цикла написать программу нахождения наибольшего из пяти чисел, вводимых с клавиатуры. pascal
Ответ:
Рама8ан
08.10.2020 13:55
Разветвляющийся алгоритм
Var a,b,c,d,e:integer;
Begin
Writeln('Введите значения переменных');
Readln(a,b,c,d,e);
If (a>b) and (a>c) and (a>d) and (a>e) tnen
Writeln('Наибольшее из 5 чисел ', a)
Else
If (b>a) and (b>c) and (b>d) and (b>e) tnen
Writeln('Наибольшее из 5 чисел ', b)
Else
If (c>a) and (c>b) and (c>d) and (c>e) tnen
Writeln('Наибольшее из 5 чисел ', c)
Else
If (d>a) and (d>b) and (d>c) and (d>e) tnen
Writeln('Наибольшее из 5 чисел ', d)
Else
Writeln('Наибольшее из 5 чисел ', e);
End.
Циклический алгоритм
Type
Vector=array [1..10] of integer;
Var m:integer;
a:vector;
i:byte;
Begin
Writeln('Введите значения переменных');
For i:=1 to 5 do
Readln (a[i]);
For i:=1 to 5 do
If a[i]>a[i+1] then
m:=a[i];
Writeln('Наибольшее число ', m);
End.
0,0
(0 оценок)
Популярные вопросы: Информатика
angel2261
27.04.2020 07:38
Дана целочисленная матрица а размером м х n, где м и n вводятся с клавиатуры. сформировать одномерный массив в, где в[i] равно сумме элементов кратных трем в i-ой строке....
БПАНган
27.04.2020 07:38
Вкаких сферах человеческой деятельности может оказаться необходимым создание и использование базы данных?...
titina82003
30.07.2020 22:33
Составить на паскале программу, которая по введённому номеру месяца выводит название времени года. при написании программы использовать логические операции. при неверном...
OlgaNazarenko123
19.05.2023 23:41
Папка находящаяся внутри другой папки называестся...
dominika6
24.12.2022 07:49
Дано 3 числа найти сумму дробных чисел...
joryk2012
24.12.2022 07:49
Перечислите известные вам выделения текста...
looooooooollll
10.01.2022 23:56
Дано число m и одномерный массив x(m). составить программу, которая выводить на печать нулевые элементы...
shapovalova12345
10.06.2020 17:21
Дана величина а, выражающая объем информации в байтах. перевести а в более крупные единицы измерения информации (килобайты - к, мегабайты м, гигабайты - г)...
AndaDi
14.08.2020 06:01
Непрерывным называют сигнал: выберите один из 4 вариантов ответа: 1) принимающий конечное число определённых значений 2) непрерывно изменяющийся во времени 3) несущий...
SaLmOn4663
09.09.2020 11:33
Вспомните басни и. а. крылова: «волк и ягнёнок», «ворона и лисица», «квартет», «лебедь, щука и рак», «лисица и виноград», «слон и моська», «стрекоза и муравей». какие...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Var a,b,c,d,e:integer;
Begin
Writeln('Введите значения переменных');
Readln(a,b,c,d,e);
If (a>b) and (a>c) and (a>d) and (a>e) tnen
Writeln('Наибольшее из 5 чисел ', a)
Else
If (b>a) and (b>c) and (b>d) and (b>e) tnen
Writeln('Наибольшее из 5 чисел ', b)
Else
If (c>a) and (c>b) and (c>d) and (c>e) tnen
Writeln('Наибольшее из 5 чисел ', c)
Else
If (d>a) and (d>b) and (d>c) and (d>e) tnen
Writeln('Наибольшее из 5 чисел ', d)
Else
Writeln('Наибольшее из 5 чисел ', e);
End.
Циклический алгоритм
Type
Vector=array [1..10] of integer;
Var m:integer;
a:vector;
i:byte;
Begin
Writeln('Введите значения переменных');
For i:=1 to 5 do
Readln (a[i]);
For i:=1 to 5 do
If a[i]>a[i+1] then
m:=a[i];
Writeln('Наибольшее число ', m);
End.