В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
antonshv313p012l5
antonshv313p012l5
07.10.2022 22:11 •  Информатика

1.составьте программу, которая вычисляет значение выражения |10-√(1+x^2 )|, где х – любое число. результат вычислений должен быть выведен на экран. 2.составьте программу, которая генерирует случайное число в промежутке от 20 до 35 и выводит его на экране. 3.составьте программу, которая вычисляет гипотенузу прямоугольного треугольника при введенных значениях катетов. результат вывести на экран.

Ответ:
polycov200412
polycov200412
08.10.2020 12:08
//1
var x: real;
begin
  write('x = ');
  readln(x);
  writeln(abs(10 - sqrt(1 + x * x)));
end.

//2
begin
randomize;
writeln(random(15) + 21);
end.

//3
var a, b: real;
begin
write(' Катет a = ');
readln(a);
write(' Катет b = ');
readln(b);
writeln(' Гипотенуза = ', sqrt(a * a + b * b));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?