В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Arisha7777
Arisha7777
10.06.2020 05:47 •  Информатика

ЗАДАЧА НА ПИТОНЕ Рабочие поднимают на грузовом лифте ящики. Если ящик весит больше 180 кг, то лифт отказывается его поднимать. Напишите программу, которая будет подсчитывать, сколько ящиков было поднято на грузовом лифте и общую массу ящиков, которые лифт поднять не смог.

С клавиатуры вводятся массы всех ящиков (в кг), символ окончания ввода - это ноль.

Формат входных данных
Последовательность целых положительных чисел, на конце ноль.

Формат выходных данных
ответ в формате:

Было поднято N ящиков, но еще K кг груза ожидают внизу.

Ответ:
nicishcina
nicishcina
29.11.2021 20:30

boxes = []

count = 0

waiting = 0

for i in range(10):

  new_box = (int(input(f"Введите массу {i} ящика")))

  if new_box > 180:

     waiting = waiting + new_box

  else:

     count = count + 1

     boxes.append(new_box)

print(f"Было поднято {count} ящиков, но ещё {waiting} кг груза ожидают внизу.")


ЗАДАЧА НА ПИТОНЕ Рабочие поднимают на грузовом лифте ящики. Если ящик весит больше 180 кг, то лифт о
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?