В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
timirkapro
timirkapro
22.04.2022 05:18 •  Информатика

72 за верно выполненное 1. напишите программу, которая вводит последовательность целых чисел, заканчивающихся нулём, и определяет, сколько из этих чисел удовлетворяет условию: сумма значений цифр десятичной записи числа равна 10. 2.напишите программу, которая вводит с клавиатуры натуральное число n и определяет его факториал.что будет, если ввести большое значение n(например, 20)? 3.напишите программу, которая определяет, верно ли, что введённое число содержит по крайней мере 2 одинаковые цифры, возможно, не стоящие рядом(как, например, 212)

Ответ:
timirkapro
timirkapro
08.10.2020 11:48
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

№1

function IsGood(n:integer):boolean;
begin
  n:=Abs(n);
  var s:=0;
  while n>0 do begin
    s+=n mod 10;
    n:=n div 10
    end;
  Result:=s=10
end;

begin
  var k:=ReadSeqIntegerWhile(t->t<>0).Where(t->IsGood(t)).Count;
  Writeln(k,' чисел с суммой цифр, равной 10')
end.

Пример
-5234 20043 52340 10531 -64 31502 0
2 чисел с суммой цифр, равной 10

№2

begin
  var n:=ReadInteger('Введите число:');
  if n<=1 then Writeln(n,'!=',1)
  else Writeln(n,'!=',1.To(n).Aggregate(BigInteger(1),(i,j)->i*j))
end.

Примеры
Введите число: 5
5!=120

Введите число: 20
20!=2432902008176640000

Введите число: 100
100!=93326215443944152681699238856266700490715968264381621468592963895217599993229915608941463976156518286253697920827223758251185210916864000000000000000000000000

№3

begin
  if ReadInteger('Введите число:').ToString.GroupBy(t->t).
      Select(t->(t.Key,t.Count)).Any(t->t[1]>1)
  then Writeln('Число содержит по крайней мере две одинаковые цифры')
  else Writeln('Введенное число не содержит одинаковых цифр')
end.

Примеры
Введите число: 12345670
Введенное число не содержит одинаковых цифр

Введите число: 1320624
Число содержит по крайней мере две одинаковые цифры
0,0(0 оценок)
Ответ:
cheropitan
cheropitan
08.10.2020 11:48
1)
var i,a:Integer;
begin
a:= 1;
while a<>0 do
begin
Read(a);
i+=a;
end;
WriteLn(i=10);
end.

2) Можно через double. Но после 170! уже бесконечность.
var n:Integer;
var b:double;
begin
b:=1;
Read(n);
for var i:= 1 to n do
b*=i;
WriteLn('factorial '+n+' = '+b);
end.

3) Работает как и с числами так и со строками.
var arr:array of char;
var a:String;
var first,last:Integer;
begin
Read(a);
arr:= a.ToCharArray();
for var i:= 0 to arr.Length-1 do
begin
first:=Pos(arr[i], a);
last:=Pos(arr[i], a,first+1);
if (first>0) and (last > 0) and (first<>last) then
begin
first:=99;
break;
end;
end;
if first = 99 then
WriteLn('Содержит. Это число '+arr[last-1])
else
WriteLn('Несодержит.');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?