В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
alinks792
alinks792
08.05.2022 18:35 •  Информатика

Составить программу на паскале. в массиве хранится информация о стоимости каждой из m книг. определить количество самых дешевых книг(с одинаковой минимальной ценой)

Ответ:
лиза2740
лиза2740
04.10.2020 08:03
Var mas:array of integer;    min,kol ,j, i,n:integer;
begin
Randomize; min:=0;kol:=0;
write('n:' );
readln(n);   
setlength(mas,length(mas)+n);///динамический массив вы можете заменить на статический 
 For i:= 0 to high(mas) do 
  mas[i]:=Random(50);   
min:=mas[0]; 
 for j:=0 to high(mas) do//ищем минимальную ценну 
 if min>mas[j] then 
 min:=mas[j] ; 
 For i:= 0 to high(mas) do 
 if min=mas[i] then//ищем количество книг с минимальной ценой
   inc(kol);   
write('kolvo min  ',kol); 
 readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?