Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
klarabuhantsova
20.04.2023 03:14 •
Информатика
Водномерном массиве состоящем из 40 элементов и принадлежащих интервалу [-11; 5] найти сумму всех положительных элементов и вывести её на экран
Ответ:
dulat15
21.08.2020 13:33
Var i,s: integer;
a: array [1..40] of integer;
begin
for i:=1 to 40 do
a[i] := random (17)-11;
writeln ('Массив ',a);
for i:=1 to 40 do
if a[i]>0 then s:=s+a[i];
writeln ('Сумма всех положительных элементов равна ',s)
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
rkdkeidkoks61
15.04.2023 20:27
Сколько килобайт составит сообщения из 384 символов 16 символьного алфавита...
Айсара777
02.11.2021 04:28
1.Опишите назначение табличных процессоров. Приведите примеры табличных процессоров. 2. Опишите прикладное программное обеспечение, которое установлено на вашем компьютере...
Dwtop1
18.08.2020 20:13
Витя пригласил своего друга сергея в гости, но не назвал ему код цифрового замка своего подъезда, а послал следующее sms-сообщение: в последовательности чисел 4, 3, 8, 2,...
romanova385
18.08.2020 20:13
Введены 2 числа, a и b,выясните, имеет ли решение уравнение 1/(a+b). , ! напишите программу паскаль...
danialSANDY
18.08.2020 20:13
Написать программу которая с клавиатуры вводит 5 целых чисел и вычисляет среднее арифметическое нечетных среди них.на abc паскале...
Анастасия0411
18.08.2020 20:13
Задан массив размером 4х3 заполненный произвольными числами в диапазоне [15,19]. посчитать сумму элементов каждой строки...
Ravik2K
03.02.2022 21:08
Нужно создать программу паскаль авс, где перед нами предстает выбор тестов. например: тест по русс.яз тест по тест по тест по тест по обществознанию можете просто пару вопросов...
avomilag95
05.05.2020 15:57
Нужно решить все задания, решение необходимо...
Q666Princess666Q
05.08.2021 16:18
Найдите строку с ошибкой и выпишите её в исправленном виде. Программа должна написать фразу правильно с нужными пробелами. program prog_2; begin write( Hello, ); writeln(...
matv
31.01.2020 00:34
Дан одномерный массив. Запиши верный ответ. −16 30 0 −2 4 14 Значение элемента массива — 14. Индекс элемента массива —...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
a: array [1..40] of integer;
begin
for i:=1 to 40 do
a[i] := random (17)-11;
writeln ('Массив ',a);
for i:=1 to 40 do
if a[i]>0 then s:=s+a[i];
writeln ('Сумма всех положительных элементов равна ',s)
end.