В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
koptevartem050
koptevartem050
24.07.2021 14:10 •  Информатика

Написать программу , которая вычисляет среднюю температуру воздуха за всю неделю. выясните, сколько раз в неделю температура была выше нуля.

Ответ:
Альба294
Альба294
08.10.2020 04:12
Program Temperatura;

Var  d, k, T: integer;  f: byte;  a: array [1..7] of integer;

Begin  f := 0;k := 0; 

Writeln('Введите температуру'); 
 for d := 1 to 7 do  Begin   
 Write(d, ' день: ');   
Readln(a[d]);     
 end; 

 for d := 1 to 7 do    if a[d] > 0            then   
 Begin     
k := k + 1;   
f := 1;   
end; 

 if f = 0        then    Writeln('Всю неделю температура была  ниже нуля.') 
else   
Writeln('Дни с температурой выше нуля - ', k); 
  
T := a[1] + a[2] + a[3] + a[4] + a[5] + a[6] + a[7]; 
WriteLn('Средняя температура за неделю:', T / 7:0:2);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?