В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ник5032
ник5032
20.03.2020 19:22 •  Информатика

Написать программу , которая увеличивает число на 7, если оно меньше нуля и уменьшает на 2. если исходное число больше 0

Ответ:
ALENAFOKS
ALENAFOKS
02.10.2020 16:16
Var a,b,c:integer;
begin
writeln('введите число');
readln(a);
if a<0 then b:=a+7 else b:=a-2;
if a=0 then while a=0 do begin writeln('введите другое число'); end;
writeln('полученное число ', b);
end.
0,0(0 оценок)
Ответ:
Анастасиюшечка
Анастасиюшечка
02.10.2020 16:16
var x : real;
begin 
 writeln ( 'Введите число : '); 
 readln (x); 
  if (x<0) then x:=x+7  
  else if (x>0) then x:=x-2; 
 writeln (' Конечное число : ',x);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?