В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Fokus123123
Fokus123123
23.06.2020 11:46 •  Информатика

Решить уравнение ax^3+bx для произвольных a, b. составить программу на паскале.

Ответ:
mrvlad12
mrvlad12
08.10.2020 03:07
Var a,b: real;

begin
readln(a, b);
if a=0 then   if b = 0 then writeln ('x - любое значение') 
else writeln ('x1 = 0');

if a>0 then  if (b>=0) then writeln ('x1 = 0') 
else writeln('x1=0 ', 'x2=',-sqrt(-b/a),' ', 'x3=',sqrt(-b/a));

if a<0 then  if (b<=0) then writeln ('x1 = 0') 
else writeln('x1=0 ', 'x2=',-sqrt(b/-a),' ', 'x3=',sqrt(b/-a))

end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?