В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
4747384673838
4747384673838
12.07.2021 05:26 •  Информатика

Написать программу ввода целых чисел с клавиатуры ,пока не будет введён 0

Ответ:
LERa007123
LERa007123
08.10.2020 02:36
{с клавиатуры вводится число a, до тех пор, пока не будет введен 0. Начальное введенное a записывается в min  и max, чтобы потом в цикле было с чем сравнивать}
var
min,max,a:real;
begin
   readln(a);
   min:=a;max:=a;
    while a<>0 do
        begin
             readln(a);
                 if a>max then
                     max:=a;
                 if a<min then
                      min:=a;
         end;
writeln('min: ',min,'  max: ',max);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?