В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
MackTraher
MackTraher
12.03.2022 04:34 •  Информатика

Pascal. составить программу которая позволяет вывести трех значное число, если первая цифра числа четное,то поменять местами последнию и среднию,иначе поменять первую и среднию. за эту 15 .

Ответ:
abaevadilnaz
abaevadilnaz
30.04.2020 14:48
Var S,a,q:integer;
b,c:real;
begin
readln(S); // вводим трёхзначное число
a:= (S div 100) mod 2; // получаем 1 цифру
if a = 0  then begin // проверяем 
b:= S div 10;   
b:= b - S div 100 * 10 ; // "вытаскиваем" среднюю цифру 
c:= S mod 10; // берём последнюю  writeln(S div 100,c,b); 
end
else begin 
b:= S div 10;   
b:= b - S div 100 * 10 ; // повторяем со средней цифрой 
c:= S mod 10; // берём последнюю (также повторяем) 
writeln(b,S div 100,c); 
end;
end.

Наверно можно было и попроще
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?